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About This Guide 
This guide is intended for CRM system administrators who wish to understand the installation, configuration and customization 

of eMap. 

Installation 
The trial of eMap can be installed by following these steps: 

Register for an account at http://downloads.mycrmgroup.com 

 Once logged in, get a Product Key for eMap 

 Download the MyCRM Licence Manager installer 

 The installer will guide you through the process of installing the MyCRM Licence Manager in your CRM instance 

 Once you have the Licence Manager installed, open up your CRM instance and go to Settings -> Extensions -> MyCRM 

Licence Manager 

 Click the Install New Product button and enter your eMap licence key 

 The Licence Manager will guide you through the process of installing the eMap solution 

Default Data 
Once eMap is installed in your CRM you may install the default maps and geocode configurations to get up and running 

quickly. This is recommended for demonstration and trial purposes. 

Experienced eMap administrators can skip this step and build out their own configurations if preferred. 

 Go to Settings -> Customizations -> Solutions 

 Double-click the eMap solution to open the Solution 

 Click the “Install Default Data” button (found under Configuration if the Solution does not open it by default): 

 

The default data installation should only take a few seconds to a minute. Once complete, you’re ready to go! 

User Role 
A new security role, eMap User, is installed with eMap. This role should be given to all end-users of eMap. If preferred, the 

permissions contained in the role can be examined and added to an already existing role. 

http://downloads.mycrmgroup.com/
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Geocoding 

Geocoding is the process of converting a street address to latitude and longitude co-ordinates to pinpoint a location on a map. 

In order to display a CRM entity’s location on a map, an entity must have enough relevant address information for the Bing 

Maps geocoding service to successfully geocode its location. A postal code alone will be enough to geocode to the postal area, 

but more accurate geolocation will only be possible where an entity has a house/business address number, street name, city 

and so on. 

The more accurate your address information in your CRM entities is, the more accurate the resulting location on the map will 

be. 

Geocoding in CRM with eMap 
In order to geocode entity addresses in CRM, you must first set up an Entity Geocode Configuration for that entity. Once eMap 

is installed, you will find Entity Geocode Configurations in Settings -> Extensions: 

 

The eMap default data contains geocode configurations for Account, Contact, Lead and User. These are the four main entities 

that include latitude and longitude fields out-of-the-box. By default, the configurations use the Address1_ fields to geocode. 
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Creating and Editing Entity Geocode Configurations 
An Entity Geocode Configuration takes fields from any CRM entity and maps them to fields used by the Bing Maps geocoding 

service. Here, for example, is the default Account configuration: 

 

The fields in the drop-down boxes are your entity fields in CRM. The field labels refer to the address field as used by Bing. For 

instance, Address Line 1 on the Bing service is mapped to the Address 1: Street 1 field on the Account in CRM. 

Note: Only text fields, option sets (picklists) and lookups are supported for the address field mappings. If an Option Set or 

Lookup is used as a geocode field, the display text of the option or lookup entity will be used. 

The Latitude and Longitude mappings are the fields that the resulting Lat/Long co-ordinates from Bing are written to in CRM. 

Most default entities in CRM that have address fields also have corresponding Latitude and Longitude fields. If you are mapping 

a custom entity’s address fields, you will need to create Latitude and Longitude fields to store the geocode information. 

Note: Latitude and Longitude fields must be defined as Floating Point Number types. 

Default Country 

The text content of the Default Country field is used during geocoding when the mapped Country field is blank for the entity 

being geocoded. Using Account as an example, the geocoding process will first look at the Address 1: Country/Region field for 

data. If there is no data, the default country will be used.  

Scenario: If your company is based in the UK, and you mostly work with Accounts in the UK your users may not always fill in the 

Country field with “UK”. The Country field might only be used when an Account is outside of the UK. Supplying “UK” as the 

Default Country will then restrict geocoding to addresses within the UK (where a Country is not entered on the entity), 

providing more accurate results for the majority of your Accounts in CRM. 
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The Geocoding Process 
Once some Entity Geocoding Configurations have been defined, there are three ways to begin the Geocoding process. 

Manual Geocoding of all entities for a configuration 

On the Entity Geocoding Configuration form, there is a tool to run that geocoding configuration against all matching entities in 

CRM: 

 

Once all of the required fields have been mapped, simply hit the “Run Geocode Now” button to begin the geocoding process. 

This will run against all entities of the type defined in the “Entity” drop-down. You will see progress counters as the geocoding 

process runs. 

Entities Examined: A count of entities that the tool has processed. 

Entities Skipped: An entity will be skipped if a) there is not enough address information to perform a geocode; or b) the entity 

already has information in the Latitude or Longitude fields. You can force a re-geocode on entities that already have a Latitude 

or Longitude by checking the “Re-geocode already geocoded entities” box before running the geocode. 

Successful Geocodes: The number of entities that were successfully geocoded by the Bing Maps Geocoding service. 

Unsuccessful Geocodes: The number of entities that could not be geocoded. This will be due to bad address information in one 

or more of the address fields. 

The Geocoding plugin 

eMap includes a plugin that runs on Create and Update of any entity that has an Entity Geocode Configuration set up for it. 

A geocode will only be attempted if one or more of the entity’s address fields (as configured) are updated, or included when 

the entity is created. 

By default, the plugin runs synchronously, which means there may be a slight delay when saving the entity form as the 

geocoding process takes place. 

The Create plugin step will run on a data import so you can be sure that imported records will be geocoded providing that the 

correct address fields are mapped and imported successfully. 

The plugin can be disabled via Settings -> Customizations -> Customize the System if required. The plugin does not need to be 

enabled for the manual geocoding process, as described above.  

The plugin steps may also be configured using the CRM Plugin Registration tool if you wish to set the plugin to only run on the 

entities that you have Geocoding Rules set up for. You may also set the plugin steps to run asynchronously. 
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On-Demand Geocoding 

On-Demand geocoding is a new feature in eMap version 1.1.2.2011 and above. It introduces a new ribbon button on the entity 

forms and home grids for Account, Contact, Lead and User (the entities that have Geocoding Rules installed by default). eMap 

users can geocode single entities (via the form button) or multiple entities (via the grid). 

On-Demand geocoding is useful if you do not wish to use automatic geocoding and instead wish to geocode only a few entities 

on an ad-hoc basis. 

The On-Demand button can be placed on other entity ribbons (including custom entities) by following the instructions in the 

separate guide “Adding On-Demand Geocoding to a Custom Entity” available from the MyCRM Download Centre. 
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Map Configuration 
eMap allows you to flexibly create new maps that can be displayed in one or more of three places: 

 The Master Map, initially installed at the top of Workplace -> My Work: 

 

 On a dashboard: 

 
 

 On an entity form: 
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Creating a New Map 
In Settings -> Extensions -> Map Configurations, click the “New” ribbon button. You will be given a blank Map Configuration to 

fill out: 

 

General 

Name: A friendly name for your map. For example: “Active Accounts”, “Open Cases” etc. 

Available on Master Map: When checked, the new map will be available to select on the Master Map in Workplace. It will be 

available to all eMap users to view. You should not check this option if you are creating a Map that will be displayed on an 

entity form (see later). 

Appearance 

Is Data Paged: (On by default) eMap loads data from your CRM view onto the map either with or without paging. With paging 

turned on, records are loaded a maximum of 1000 at a time, according to the area you are viewing on the map. Panning and/or 

zooming will refresh the data accordingly. 

With paging tuned off, all data is loaded up-front when the map loads. This can take a long time with views that have more 

than 10,000 records.  

Some map features (Entity Distance Filtering and Route Filtering) require all records to be loaded to work. If Data Paging is off 

when one of these features is used, all records will be temporarily loaded. 
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Default Map View: The default Bing Maps imagery that will be used on the map. Either Road, Aerial or Automatic. 

Enable Map View Selection: Determines whether the end-user will be able to change the Map imagery as set in the Default 

Map View option. 

Enable Pan and Zoom:  If disabled, the end-user will not be able to pan and zoom on the map – the map will be locked and 

zoomed on the available pins. This option might be useful where a map is used only for display purposes such as on a 

dashboard or entity form. 

Click to Open Popup: Pin popups will be opened with a click instead of on mouse hover. 

Shrink Pins Below Zoom Level: Sets a zoom level below which a small version of the pin icon will be used. The map has a zoom 

level of 0-20, with 0 being zoomed out the furthest. Recommend setting this to around 8 with maps that have more than a few 

records. 

Heat Map Enabled: Enables the toggling on/off of the heatmap view. Heatmaps require CRM Rollup 12 and an HTML5 

compliant browser. 

Heat Map on by default: The map will start up in heatmap view mode 

Heat Map default intensity: The level of intensity of the heatmap view. This should be higher for maps that are likely to have a 

smaller number of pins. 
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Default Pan and Zoom (new in 1.1.3) 

Map Center: By default, eMap will pan and zoom the map so that all pins are visible. If this option is set to “Form Entity”, the 

map will center on the pin that represents the form’s entity. Note that this option is only available for maps that are placed on 

a form and where a Form Entity layer is used. 

Future versions of eMap will include an option to center on the current CRM User’s location, and an option to set an arbitrary 

point to center the map. 

Zoom: Sets the default zoom level (1-20 as per Bing Maps zoom levels) when the map center is not set to “All Pins”. 

Legend 

Show Legend: Determines whether the legend (showing pin colours and entity names) will be visible on the map. 

Enable Layer Show / Hide: When disabled, the end-user will not be able to toggle visibility of individual map layers. 

Enable Layer Filter Change: When disabled, the end-user will not be able to alter the data filtering on a layer, other than by 

using eMaps features. 

Features 

Enable Features: A master option that will completely enable or disable map Features. If disabled, the Features bar on the 

right of the map display will not be shown, regardless of whether an individual Feature is enabled or disabled. See the user 

guide for explanation of the individual features. 

Local Search: Enable the Local Search feature, and set it on or off by default. See the user guide for more information on Local 

Search. 

Layers: A regular related entity grid that allows you to add and remove layers from the map (see below). 
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Map Layers 
Map layers are at the heart of eMap’s flexible ability to display data on a map. Each Map Configuration must have at least one 

Layer in order to display data. Each layer is linked to an entity type and determines the set of data that eMap will display for 

the selected entity.  

Layers are so-called because they are drawn on the map in order from top (layer order 0) to bottom (layer order n). For 

instance, if you have a layer with display order 0 containing Account data, and a layer with display order 1 containing Contact 

data, the Account pins will appear on top of the Contact pins when displayed on the map. 

Data Sources 

Layers user CRM Views to determine which data is displayed on the layer. For example, selecting the “Active Accounts” view 

when setting up an Account layer will only show Active Accounts. Selecting “My Accounts” as the view for a layer will display 

the Accounts that are owned by the end-user that is viewing the map. You could set up custom views in CRM to show different 

sets of data for the selected entity. 

There is one exception to using Views: when setting up a map that will be displayed on an entity form, you may wish to have a 

layer that will show the location of only the entity that has been opened. In this case you would use the Form Entity data 

source. 

Geocode Sources 

By default, layers will take their location from the latitude and longitude fields as set up in the Entity Geocode Configuration for 

the layer’s selected entity. There are times when you will need to get geocode information from a related entity. 

Example: Opportunities contain no address information. You may however wish to create a layer that displays Opportunities 

on a map. In order to get a location for an Opportunity, you would look at the related Customer entity. This will allow the layer 

to place Opportunity pins at the geocoded location of the Contact or Account that is provided as a Customer on the 

Opportunity. 

Form Entity Filtering 

Scenario: “I wish to create a map that will be displayed on the Account form. I want this map to display the location of the 

Account that I open, but I also want to display the location of all the Contacts associated with that Account” 

We can use the special Form Entity Filter layer option to provide this functionality. In the given scenario, the Map would have 

two layers: One Account layer that has a Form Entity data source, and a Contact Layer that uses the Active Contacts view as its 

data source. 

On the Contact Layer, we would select “Parent Account” as the Form Entity Filter. This will then display Active Contacts where 

the Parent Account is the Account displayed on the open form. Behind the scenes, the filter takes the ID of the entity of the 

current form and adds it to the selected view’s pre-created filter. 

Form Entity Filtering is a powerful feature that is useful any time a map is added to a form for an entity that has a one-to-many 

relationship with another entity. 
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Creating a New Map Layer 
Map Layers can only be created via the related entity grid of a Map Layer Configuration. When you click the New Map Layer 

button, the following form is displayed: 

 

Map Configuration: The map that this layer will be displayed on. This lookup will be set automatically. 

Layer Order: The order that the layer will be displayed in. 0 is the topmost layer. When this value is changed for one layer on a 

map - or if a layer is deleted - the rest of the layers for that map will have their display orders updated.  

Entity: The entity type that will be displayed on this layer. 

Layer Display Name: A friendly name for the map layer, as displayed in the Legend. Defaults to the entity name. 

Data Source: Either View or Form Entity. See the previous page for a description of Data Sources. 

View: Only available if the Data Source is set to View. The view that will be used to gather data to display on the Layer. 

Allow user to change layer view: Only available if the Data Source is set to View. This option makes a drop-down list of views 

available to the user from the map legend. Personal views are included. 

Geocode Source: Either This Entity or Related Entity. See the previous page for a description of Geocode Sources. 

Related Entity: Only available if Geocode Source is set to Related Entity. The related entity that the latitude/longitude data is 

taken from. 

Form Entity Filter:  The lookup that is filtered by the ID of the form that the map is placed on. Only used if the layer is on a map 

that is placed on an entity form. See the previous page for a description of Form Entity Filtering. 

Pin Type: Either: Basic Color, Webresource Field or Appointment (appointment pin type only available on an Appointments 

layer) 
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Pin Color: The pin that will be used for this layer when the Pin Type is “Basic Color”. 
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Webresource Url: Choose a field from the entity that will contain the URL of a custom pin to load. When the map loads, the pin 

icon for this entity will be taken from the corresponding field. 

The URL can be CRM relative “/images/my_pin.png” if loading from a Web Resource, or absolute 

“http://mycompany.com/pins/my_pin.png” if loading from an external site. 

Loading the pin image from a URL is very powerful. For example, you could have small pins with users’ faces on them when 

setting up a User layer, or a custom coloured pin that is set by a workflow when an entity is updated (think: Job Status for a 

Case). 

Appointment: When setting up an Appointments layer, the Appointment pin type is a special pin that will show the number of 

days until the appointment (or negative if the appointment has passed). Today’s appointments will be highlighted in green. 

Display Name Field: The field that will be used as a title when displaying the popup box for this layer on the map. 

Recommended fields to use would be Name for Account/Lead, Full Name for Contact etc. 

Display Fields:  The extra fields that will be displayed on the popup box on the map. You can include any fields you like here, 

and change the display order using the up/down arrows. Most common fields to include would be relevant address fields, but 

you could use any fields that would be useful information for the end-user have at a glance. 

The fields selected here are also used as columns when using the List Creator function. See the user guide for more 

information. 
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Map Pivot Rules (new in 1.1.3) 
Define Map Pivot Rules to filter one layer based on attributes of a single selected entity on a second layer.  

Example usage: Default map with Account layer and Contact layer. User clicks Pivot on an Account pop-up. This will:  

a) Hide all other accounts and 

b) filter Contacts layer so only Contacts belonging to the selected Account are shown.  

Multiple rules can be defined if you wish to filter on more than one attribute. 

 

Name: A friendly name for this pivot rule 

Map: The map that the pivot rule belongs to (automatically populated) 

When only one entity is shown on layer: Known as the Pivot layer, this is the layer that will have the “Pivot” button shown in 

the pin popups: 

 

Filter layer: The layer that the will be filtered 

Where: The attribute on the filter layer that will be matched to the “Is equal to:” field on the pivot layer 

Is equal to: The attribute on the pivot layer that will be used to filter. When the pivot is active, the filter layer will only show 

pins where this attribute is equal to the Where attribute on the Pivot layer.  
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Adding Maps in CRM 
So, you’ve created a new Map and added Layers to it. Now it’s time to get it displayed to end-users in CRM. Maps that are 

enabled for display on the Master Map will automatically be available on the Master Map under Workplace -> My Work. The 

end-user can choose between any available Master Maps by using the Map Selector dropdown box. 

Adding Maps to entity forms and dashboards requires a little customization, and will be detailed below. 

Map IDs 

In order to place a map on a form or dashboard, we need to know the Map ID. Once a Map Configuration has been created, 

the Map ID is displayed on the Map Configuration form, as shown: 

 

The Map ID can be copied from here and used in the detailed scenarios below. 

Removing or Relocating the Master Map 

The Master Map is created via a standard CRM Site Map entry and can be removed or relocated using any number of CRM 

2011 Sitemap Editors available, or by exporting the sitemap and editing it manually. 

The Master Map is added to the site map via the myce_/eMap_Master.html web resource. The following image shows the 

Master Map sitemap entry in a popular free Site Map editing tool:  
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Changing the Default Master Map 

By default, the Master Map will display the first map in the list of Maps that are available for display on the Master Map, 

sorted alphabetically by Name. You can specify a default map by adding to the Web Resource URL in the site map. 

In the screenshot below, we use the Sitemap Editor tool to add ?data=<map ID> to the myce_/eMap_Master.html url: 

 

Here, we used the ID copied from the “My Open Leads” map in the Map IDs section screenshot on the previous page and 

appended it to the myce_/eMap_Master.html web resource URL. As a result, the My Open Leads map is now shown by default 

on the Master Map page: 
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Displaying a Map on a Dashboard 

You can use the CRM Dashboard Editor to place Maps on a dashboard section. Select Web Resource when editing a dashboard 

section, and then set the Web Resource’s properties as follows: 

 

Web Resource: Select the myce_/eMap.html resource (note: do not use the myce_/eMap_Master.html resource on a 

dashboard section) 

Name / Label: Can be set as required. It is not recommended to set the “Display label on the Dashboard” option, as this causes 

cut-off issues when used with an HTML web resource. 

Custom Parameter(data): Paste your copied Map ID into this box. The corresponding map will be used in this dashboard 

section. 

You may display as many maps as you like on one dashboard.  

It is recommended that Features are turned off when displaying a map on a dashboard, especially if the map is constrained to a 

small portion of the screen. If the map needs to be fully-functional, consider a single map dashboard with a large display area 

for the dashboard section. 
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Displaying a Map on an Entity Form 

Open up the form editor for the CRM entity as normal. It is recommended (but not required) that a new Tab is set up for the 

Map to be displayed in. 

Create a new form section and insert a web resource via the Insert tab: 

 

Set the Web Resource properties as follows: 

 

Web Resource: Select the myce_/eMap.html resource (note: do not use the myce_/eMap_Master.html resource on a form) 

Name / Label: Can be set as required. 

Custom Parameter(data): Paste your copied Map ID into this box. The corresponding map will be used on this form. 
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On the Formatting tab: 

 

Layout: Two columns. 

Row Layout: 6 rows is the absolute minimum space required for a map, and it is recommended to use “Automatically expand 

to use available space”. 

Scrolling: As necessary. 

Border: Off. 

 


